Sunday, 8 December 2013

Site Owner can't edit the page! Access Denied?

Background

A user who was the owner of a site collection was trying to edit the site's home page but was getting "Access Denied" error! As a site collection administrator I could edit the page fine but the site owner could not. Turned out that the user didn't have access to Master Pages Gallery! I found out that the master pages library had unique permissions. To solve the problem, I granted the user "read" permission on the library and the problem was solved!

Short Steps

  1. Go to master pages library
  2. Open library permissions
  3. add the user with "read" permission

Detailed Steps

1. Go to master pages library. Click Site Actions > Site Settings > Master pages and page layouts


2. Open library permissions


3. Add the user with "read" permission


 


















After this the user should be ready to edit the home page of the site.

Tuesday, 26 November 2013

Deleting a Custom Timer Job from SharePoint 2010

Background

I was tasked with deleting a custom timer job from our SharePoint 2010 server environment. The timer job was created and deployed as a farm solution (.wsp file) three years ago and was responsible for updating the users' regional settings. Because the job was causing an issue and also because we had written and scheduled a new Powershell script for the task (which I will share in a future post), we decided to remove this custom timer job completely.

Short Steps

Here are the short three steps I performed to remove the timer job:
  1. Disable the timer job for all web applications
  2. Uninstall the solution (.wsp) for the timer job
  3. Remove the solution from the farm

Detailed Steps

1. Disable the timer job for all web applications from Central Administration. Go to CA > Monitoring > Review job definitions.














2. From the list of timer jobs, select the timer job that you want to remove.
3. On the Edit Timer Job page, disable the timer job.














4. After disabling the job, retract and remove the custom solution (.wsp) from the farm. Go to CA > System Settings > Manage Farm Solutions, then select the solution that you want to delete and click on the Retract Solution










5. When the solution has been retracted, remove the solution.










When the solution is removed successfully, the timer job would be deleted from the farm completely and will not be listed in the timer job definitions.